Redshift not showing any value in reports


I was glad to hear that Helical Insight now support Redshift also. I tried to use my existing Helical version 4.1 and created connection with Redshift and also metadata. But when I use this metadata to create report, my report does not show any result. As if all tables are empty, which is incorrect. I tried the latest version of application HI 5.0 but still the same result. What am I missing?


Hello Netta,

There is a minor change in the dialect of redshift. We would make this as default part of the build of Helical Insight. The SQL generated is missing the schema name before the table name and redshift is not able to fetch the data (in the ‘from’ clause). Please perform the following steps and you will be able to work seamlessly.

  1. Download file and extract redshift.js file from the downloaded zip.

  2. Take back up of existing redshift.js file from below location (just as a precaution)

  3. Upload redshift.js file which you have extracted from zip at location

Clear Helical Insight application and browser cache OR check in private window.

You will be able to make reports easily.

Helical Insight.