Email Scheduling reports does not work

Dear Team,

I am trying to schedule a report. I opened a report from the File Browser and tried to email schedule it.

There are no parameters hence I moved to next step i.e Email Options. In this step it asks to select a Report Name. When I click Select button, it takes me to File Browser, but it does not show me any report in the folders.

image

image

image

My question is:

  1. When I am scheduling a report from the option ‘Email / Schedule’ which is present on the report itself, scheduling should not ask the report name, rather it should take the report name by default.

OR

  1. After going into the File Browser from ‘Select’ button to select the report, it should me all the report to which I have access. Not sure why it does not show the report list and shows the folder hierarchy only.

Hi Pushpal,
Whenever a person schedules a report/dashboard, our application makes a copy of the report/dashboard as a saved result file with the extension SR. This saved result file is basically having the report/dashboard along with the input parameters which have been selected.

So with file browser what you are basically doing is selecting a path where this SR (saved result) file gets saved.

Hope this helps.

Thanks

Thanks Team ! I Tested this. However the report did not get emailed to the recipient.

Is it because report first exports in selected option (pdf, png etc)? In our trial instance, we are not able to export the report in PNG,JPG,PDF etc.

Also error is not so understandable.

It seems like the file responsible for exporting is not having the adequate permission or the path is incorrect. Since export is also not working, thats why the email scheduling is also not happening. Please follow the below 2 troubleshooting instructions

a. Phantom.js : Please check whether this file is having executable permission or not. If not provide it by entering command
Chmod 777 locationofthefile linux_phantom.js

Generally the location of this file is “C:\Program Files\Helical Insight\hi\hi-repository\System\Reports”
In case if you are using some other OS then that respective OS_phantom.js file should be given that specific permission. Here we have assumed that you are using linux and that’s why we have mentioned linux_phantom.js. In case if it’s windows the file name is “windows_phantomjs” and in case of MAC the file name is “macosx_phantomjs”

b. Open settings.xml located in the path “C:\Program Files\Helical Insight\hi\hi-repository\System\Admin”.
Check the base URL and hi-repository path whether it is correctly configured or not.

i.e. check the lines 4 and 5
C:\Program Files\Helical Insight\hi\hi-repository
http://localhost:8085/hi-ee/hi.html

Restart the tomcat server once and check whether the export is happening or not.

thankyou

Dear Team,

We tried the steps you provided :

a. Phantom.js : Please check whether this file is having executable permission or not. If not provide it by entering command
Chmod 777 locationofthefile linux_phantom.js

b. Open settings.xml located in the path “C:\Program Files\Helical Insight\hi\hi-repository\System\Admin”.
Check the base URL and hi-repository path whether it is correctly configured or not.

And restarted the tomcat server.

But still getting the error:

image

Any other step that we are missing?

Dear Team,

Any updates on this?

Regards
Pushpal